Vlan over EOIP Tunnel by Using Bridge

Pahrial Ms
2 min readAug 29, 2021

--

Part 1, R1 and R2 device configuration.

Configure IP Addresses R1 and R2 :

#R1

/ip address
add address=10.10.10.1/24 interface=ether1

#R2

/ip address
add address=10.10.10.2/24 interface=ether1

Configure eoip interface to establish a tunnel connection :

#R1

/interface eoip
add name=Eoip-to-R2 remote-address=10.10.10.2 tunnel-id=100

#R2

/interface eoip
add name=Eoip-to-R1 remote-address=10.10.10.1 tunnel-id=100

In the remote-address parameter you enter the IP Address of the opposing router (real implementation using Public IP), and tunnel-id make sure you enter the same value on both sides.

Create Bridge for vlan distribution from remote site to router distribution and vice versa, do it on R1 and R2 using the following command:

/interface bridge
add name=bridge-vlan-dist10
add name=bridge-vlan-dist20

Create interfaces vlan 10 and 20, respectively on the interface leading to router-distribution (ether2) and on the eoip tunnel interface.

#R1

/interface vlan
add interface=ether2 name=vlan-dist10 vlan-id=10
add interface=ether2 name=vlan-dist20 vlan-id=20
add interface=Eoip-to-R2 name=vlan10 vlan-id=10
add interface=Eoip-to-R2 name=vlan20 vlan-id=20

#R2

/interface vlan
add interface=ether2 name=vlan-dist10 vlan-id=10
add interface=ether2 name=vlan-dist20 vlan-id=20
add interface=Eoip-to-R1 name=vlan10 vlan-id=10
add interface=Eoip-to-R1 name=vlan20 vlan-id=20

Then after the VLAN interfaces are created on each interface, it’s time to add the VLAN interface to the bridge port. Do it on R1 and R2.

/interface bridge port
add bridge=bridge-vlan-dist10 interface=vlan10
add bridge=bridge-vlan-dist10 interface=vlan-dist10
add bridge=bridge-vlan-dist20 interface=vlan20
add bridge=bridge-vlan-dist20 interface=vlan-dist20

Part 2, R-dist1 and R-dist2 device configuration.

Create Bridge for vlan distribution from router gateway to client device and vice versa, do it on R-dist1 and R-dist2 using the following command:

/interface bridge
add name=bridge-vlan-dist10
add name=bridge-vlan-dist20

Create a vlan interface with a master interface that points to the gateway router (ether1). Do it on R-dist1 and R-dist2.

/interface vlan
add interface=ether1 name=vlan-dist10 vlan-id=10
add interface=ether1 name=vlan-dist20 vlan-id=20

Then the VLAN interface that has been created, add the VLAN interface to the bridge port. Also add an interface that points to the client device, in this case ether2 is added to bridge-vlan-dist10 and ether3 is added to bridge-vlan-dist20. Do it on R-dist1 and R-dist2.

/interface bridge port
add bridge=bridge-vlan-dist10 interface=vlan-dist10
add bridge=bridge-vlan-dist10 interface=ether2
add bridge=bridge-vlan-dist20 interface=vlan-dist20
add bridge=bridge-vlan-dist20 interface=ether3

Setelah semua mikrotik device dikonfigurasi, saat konfigurasikan IP Address pada client device sesuai dengan topologi diatas.

If all devices, both mikrotik and clients have been configured, the clients in the same vlan should be able to communicate with each other.

--

--